Welcome to Canadaquaria. Members please log in.

Please register to view all topics

Guests may view and use the Aquariums for Beginners area, Freshwater General Section without registering.

Registered members see Canadaquaria advertisement free.


Eheim canister filter setup

Post new topic   Reply to topic

Page 2 of 2 Previous  1, 2

View previous topic View next topic Go down

Eheim canister filter setup

Post by Biulu on Thu Oct 24, 2013 8:42 am

First topic message reminder :

During the annual moving frenzy here in Montreal I picked up an Eheim filter from the curbside. It came complete with hoses etc. but of course without the media.

I want to set it up and fill it with media but don't know how to. The filter comes with some plastic plates which I assume are there to make layers of different media. I know that the biological media normally go in the middle, but where do I put the sponges?

Does the course sponge go in the bottom or on the top? Same question for the polishing pad or fine sponge.

Here are 2 pictures of the filter:

" />

" />
avatar
Biulu
Support

Posts : 3692
Join date : 2013-09-12
Location : Montreal, Quebec

Back to top Go down


Re: Eheim canister filter setup

Post by Biulu on Thu Nov 21, 2013 4:12 pm

It looks like I solved the problem; I screwed the inlet a bit more into the canister and it seems as if the leaking is gone. The filter stands now in a bucket, I primed it as far as I could and it seems like the water level is slowly rising in both tubes!

Once I am confident it is actually working, I will order the quick valves on line; no use spending money on a filter that will not work properly...
avatar
Biulu
Support

Posts : 3692
Join date : 2013-09-12
Location : Montreal, Quebec

Back to top Go down

Re: Eheim canister filter setup

Post by Biulu on Thu Nov 21, 2013 8:24 pm

After I had it running, I opened up the filter to put the media back in and of course it took me some fiddling to get it going again.

It was running but it is drawing some air in at the curve in the inlet. So after half an hour it stopped running. I know I am very close and will fix this tomorrow.

In the mean time I am ordering quick valves and an inlet strainer.
avatar
Biulu
Support

Posts : 3692
Join date : 2013-09-12
Location : Montreal, Quebec

Back to top Go down

Page 2 of 2 Previous  1, 2

View previous topic View next topic Back to top


Post new topic   Reply to topic
 
Permissions in this forum:
You can reply to topics in this forum